Reply
DC Legends Community Manager
Posts: 65
Registered: ‎12-18-2017

iOS Users: Upcoming Release will Require iOS 8+

Hi!

 

If you are an iOS user, you will need to be on iOS 8 or higher to play DC Legends. This will go into affect in an upcoming release so make sure your iOS is up to date.

 

Again, this will only affect iOS players.